Написать программу, которая проверяет является ли введенное число двузначным или нет....

0 голосов
176 просмотров

Написать программу, которая проверяет является ли введенное число двузначным или нет. Если условие выполняется, то на экран выводятся число десятков и единиц исходного числа, иначе выводится сообщение "Число двузначным не является".


Информатика (19.6k баллов) | 176 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET 3.1 сборка 1256

Var
 a:integer;
 s:string;
begin
readln(a);
s:=inttostr(a);
if length(s)=2 then
  begin
  writeln('Десятков:',s[1]);
  write('Единиц:',s[2]);
 end
 else
 writeln('Число двузначным не является');
end.

Пример ввода:
27
Пример вывода:
Десятков:2
Единиц:7

(38.6k баллов)