Напишите программу для s=(1)+(1+2)+(1+2+3)+...+(1+2+3+...+n)

0 голосов
61 просмотров

Напишите программу для s=(1)+(1+2)+(1+2+3)+...+(1+2+3+...+n)


Информатика (21 баллов) | 61 просмотров
0

Сколько раз n повторяется?

Дан 1 ответ
0 голосов
class EachSum{
 public static void main(String args[]){
  long sum = 0;
  for(long n = new java.util.Scanner(System.in).nextLong(); n>0; n--)
   for(long sumNum = n; sumNum>0; sumNum--)sum+=sumNum;
  System.out.print(sum);
 }
}
(851 баллов)