Написать программу в Pascal, которая вычисляет площадь треугольника по двум сторонам.

0 голосов
148 просмотров

Написать программу в Pascal, которая вычисляет площадь треугольника по двум сторонам.


Информатика (210 баллов) | 148 просмотров
0

Мне кажется или тут еще нужен угол между ними?

0

Площадь треугольника равна половине произведения двух его сторон умноженного на синус угла между ними.

Дан 1 ответ
0 голосов

Program s;
uses crt;
var s,h,a:real;
begin
clrscr;
writeln('введите основание и высоту через пробел');
readln(a,h);
s:=0.5*a*h;
writeln('s= ',s);
readkey;
end.
при вводе 2 и 5 площадь будет равна 5

(655 баллов)
0

вот еще одна на всякий:

0

program a1; 
var x,y,z,p:real; 
begin 
write('Vvedite razmer pervogo kateta:'); 
readln(x); 
write('Vvedite razmer vtorogo kateta:'); 
readln(y); 
write('Vvedite razmer ugla mezhdu nimi:'); 
readln(z); 
p:=(x*y*sin(z))/2; 
writeln('Ploshad ravna:',p:6:2); 
readln; 
end.