Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день...

0 голосов
27 просмотров

Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?


Информатика | 27 просмотров
Дан 1 ответ
0 голосов

Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;

While (K>0) do
Begin
    s_el:= s_el * 1.5;
    K:=K - s_el;
    den:=den+1;
 end;

Writeln('Варенье кончится через ', den, ' дней');

readln();
end.

(3.2k баллов)