Помогите написать программу ** Паскале Дана строка символов .Проверить есть ли в этой...

0 голосов
30 просмотров

Помогите написать программу на Паскале
Дана строка символов .Проверить есть ли в этой строке все буквы,входящие в слово "тигр"


Информатика (215 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var i,n,k,z,x:integer;
s:string;
BEGIN
writeln(s);readln(s);
for i:=1 to length(s) do begin
if (s[i]='т') then n:=n+1;end;
for i:=1 to length(s) do begin
if (s[i]='и') then k:=k+1;end;
for i:=1 to length(s) do begin
if (s[i]='г') then x:=x+1;end;
for i:=1 to length(s) do begin
if (s[i]='р') then z:=z+1;end;
if ((n>0) and (k>0) and (x>0) and (z>0)) then writeln('есть все буквы')
else writeln('no');end.
(425 баллов)