Написать программу: вводятся число до тех пор пока не введен 5. Найти произведение чисел не равных нулю. Ребята очень срочно
var prod,temp:real;
begin
prod:=1;
repeat
readln(temp);
if (temp=5) then break;
if (temp<>0) then prod := prod * temp;
until (2*2=5);
writeln(prod);
end.