Помогите пожалуйста. Нужно написать программу в "Паскале" для перевода из любых систем...

0 голосов
30 просмотров

Помогите пожалуйста.
Нужно написать программу в "Паскале" для перевода из любых систем исчисления в десятичную.


Информатика (139 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  n, k, i: integer;
  s: string;
begin
  write('Введите число: ');
  read(s);
  write('Введите исходную систему счисления: ');
  read(k);
  for i := 1 to length(s) do
    n := n * k + ord(s[i]) - 48;
  write(s, '(2) = ', n, '(10)');
end.

Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)

(13.3k баллов)
0

спасибо большое, вы мне очень помогли.

0

Пожалуйста

0

можно и по другому, но это уже не ажно

0

Можно, я не спорю, способом тысяча. А строку я использовал лишь потому, что число в двоичной системе может иметь большой размер.