Написать программу,которая: 1. Создает вещественный массив из 8 элементов; 2. Заполняет...

0 голосов
41 просмотров

Написать программу,которая:
1. Создает вещественный массив из 8 элементов;
2. Заполняет массив элементами геометрической прогрессии с a0=1 и q=0.5;
3. Подсчитывает количество элементов массива, меньших 0.1
4. Присваивает симметрично значения первых 4 элементов массива значениям последних 4 элементов.
После второго и четвертого действия вывести элементы массива в столбик.


Информатика (15 баллов) | 41 просмотров
0

Симметрично относительно середины массива? Или отностительно начала массива?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1184 от 02.03.2016
begin
  var a:=SeqGen(8,1.0,i->i*0.5).ToArray; // 1 и 2
  a.Println(NewLine); // вывод
  Writeln('Меньших 0.1: ',a.Count(x->x<0.1)); // 3<br>  for var i:=0 to 3 do Swap(a[i],a[7-i]); // 4
  a.Println(NewLine); // вывод
end.

Тестовое решение:
1
0.5
0.25
0.125
0.0625
0.03125
0.015625
0.0078125
Меньших 0.1: 4
0.0078125
0.015625
0.03125
0.0625
0.125
0.25
0.5
1

(142k баллов)