Помогите написать программу (вложение)

0 голосов
39 просмотров

Помогите написать программу (вложение)


Информатика (87 баллов) | 39 просмотров
0

Все телепаты ушли в отпуск! Какой язык программирования?

0

Ну и конечно, это очень практично: картинку вложить в Word, а Word-овский документ приложить сюда! Вот сразу не судьба было приложить картинку без всяких промежуточных форматов?

0

язык паскаль, как прислали ребенку, так я и выложила

Дан 1 ответ
0 голосов

Так и не дождался ответа на вопрос о языке программирования.
Выложу для Паскаля:

Const N=10;
Var
  A : array[1..N,1..N] of Real;
  k,i,j : Integer;
Begin
  k:=0;
  For i:=1 to N do
  Begin
    For j:=1 to N do
    Begin
      A[i,j]:=sin((i*i-j*j)/N);
      Write(A[i,j]:6:2);
      If A[i,j]>=0 then Inc(k);  { если не считать 0 положительным, то условие будет A[i,j]>0 }
    end;
   Writeln;
  end;
  Writeln('Положительных элементов: ',k);
end.

(5.1k баллов)
0

Спасибо. P.S. Добрее нужно быть к родителям, которые и сами мало что понимают )))))

0

Я и сам "родитель", причём вдвойне... и поверьте, это я еще добрый.