Напишите программу, которая получает натуральные числа A и B (A<B) и выводит все простые...

0 голосов
135 просмотров
Напишите программу, которая получает натуральные числа A и B (A
На языке C.

Информатика (36 баллов) | 135 просмотров
Дан 1 ответ
0 голосов

#include
#include
#include

bool simpl(int n)
 { 
   int k=0;
   for (int i=2; i<=sqrt(n); i++)<br>   if ((n % i)==0)   {  k=1;  break; }
   if (k==0)  return true;
   else return false;
 }

int main() { 
     int a,b;
     printf("A = ");  scanf("%i",&a);
     printf("B = ");  scanf("%i",&b);
     for (int i=a; i<=b; i++)<br>       if (simpl(i)) printf("%i  ",i);
     printf("\n");
     getch();
    return(0);
}

(9.7k баллов)