Умоляю Срочно Напишите программу ** паскале подробно

0 голосов
18 просмотров

Умоляю
Срочно
Напишите программу на паскале подробно


image

Информатика (119 баллов) | 18 просмотров
0

Как можно писать программу ПОДРОБНО или НЕ ПОДРОБНО?

0

vara,b:array [1..12] of integer;z,i:integer;beginz:=4;for i := 1 to 12 do  begin  a[i]:=random(12)-3;  write(a[i],' ');  end;  writeln;    for i:=1 to 12 do    begin    b[i]:=a[z];    z:=z-1;    if z=0 then z:=8;    if z=4 then z:=12;    write(b[i],' ');    end;end.

Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var a:=ArrRandom(12,10,99);
  a.Println;
  for var i:=0 to 1 do begin
    Swap(a[i],a[3-i]);
    Swap(a[i+4],a[7-i]);
    Swap(a[i+8],a[11-i])
    end;
  a.Println  
end.

Тестовое решение:
33 23 98 13 22 79 31 38 71 30 48 53
13 98 23 33 38 31 79 22 53 48 30 71

(142k баллов)
0 голосов

Думаю похоже на то,что тебе нужно.


image
(356 баллов)
0

Отформатируйте текст, пожалуйста!