Pascal!Даю 30 балов!!1!!!! Написать программу,помогите Дано 4-х значное число<вычислить...

0 голосов
31 просмотров

Pascal!Даю 30 балов!!1!!!!
Написать программу,помогите
Дано 4-х значное число<вычислить произведение его чисел


Информатика (58 баллов) | 31 просмотров
0

произведение его ЦИФР?

Дан 1 ответ
0 голосов
Правильный ответ

Var a,a1,a2,a3,a4,p:integer;
begin
write('a = '); readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
p:=a1*a2*a3*a4;
writeln('p = ',p);
end.

Пример:
a = 2345
p = 120

(194k баллов)