1) напишите программу которое вводит натуральное число"n" и находит сумму всех...

0 голосов
271 просмотров

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока).
2)напишите программу которое вводит натуральное число "n" и выводит первые "n" четных натуральных чисел.
3)напишите программу которая вводит натуральные числа "a и b" и выводит квадраты натуральных чисел в диапазоне от "a до b".
помогите пожалуйста , а то не понимаю)))


Информатика (25 баллов) | 271 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1.
Var
  a,n:integer;
Begin
  write('Введите число n ');
  Readln(n);
  while a<=n do<br>  Begin
    write(a,' ');
    a:=a+1;
  End;
End.
2.
Var
  a,n,d:integer;
Begin
  d:=2;
  write('Введите число n ');
  Readln(n);
  while a  Begin
    write(d,' ');
    d:=d+2;
    a:=a+1;
  End;
End.
3.
Var
  a,b:integer;
Begin
  write('Введите числа a и b: ');
  Readln(a,b);
  while a<=b do<br>  Begin
    writeln(a,'^2 = ',sqr(a),' ');
    a:=a+1;
  End;
End.

(2.6k баллов)
0

спасибо