!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!! Составить программу, которая позволяет ввести два...

0 голосов
36 просмотров

!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!!
Составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. На экран должен быть выведен результат выполнения соответствующего арифметического действия. Для ввода знака использовать вспомогательную переменную типа char.


Информатика (20 баллов) | 36 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.






(5.1k баллов)
0

По хорошему еще бы прикрутить проверку на деление на ноль, а то ведь без "защиты от дурака" код не слишком стабилен.

0 голосов

Var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.

(2.6k баллов)
0

Спасибо огромное!! <3

0

Немножко улучшил программу

0

И какое же ты нарушение нашел в моем варианте?

0

Или ты просто хочешь, чтобы стёрли подсказанную мною доработку кода, которой ты воспользовался?