Помогите написать программу ** Паскале Дана строка текста,знаков препинания в строке...

0 голосов
38 просмотров

Помогите написать программу на Паскале
Дана строка текста,знаков препинания в строке нет.напечатать все слова,заканчивающиеся на "ов"
С помощью функции Pos


Информатика (215 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1172

Var
 s:string;
 i:integer;
begin
 readln(s);
 var wo:=s.ToWords(s);
 for i:=0 to length(wo)-1 do
 begin;
 delete(wo[i],pos(' ',wo[i]),1);
 if (pos('ов',wo[i])=length(wo[i])-1) then writeln(wo[i]);
 end;
end.

Пример ввода:
Иов Петров Петрон Человек

Пример вывода:
Иов
Петров


(38.6k баллов)