Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество...

0 голосов
347 просмотров

Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово "дней" может иметь также формы "день" и "дня".
Пример:
Введите день и месяц: 25 12
Осталось 7 дней до Нового Года.
Пример:
Введите день и месяц: 1 1
Осталось 364 дня до Нового Года.
Пример:
Введите день и месяц: 31 2
Неверная дата.


Информатика (58 баллов) | 347 просмотров
0

сильно геморно для паскаля и 5 баллов

Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.

(53.1k баллов)
0

извините за плохие переносы