Напишите программу:Дается целое число n,напишите программу,которая проверяет(выявляет)...

0 голосов
39 просмотров

Напишите программу:Дается целое число n,напишите программу,которая проверяет(выявляет) если число n четное и если оно делится на 3 без остатка.
Прога на базе PASKAL и решается через оператор if.


Информатика (1.8k баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Var a,i:integer
begin
read(a)
if a mod 2 = 0 then writeln('Число чётное')
if a mod 3 = 0 then writeln('Число делится на 3')
end.

(1.7k баллов)
0

Слушай ,а как это решить глобальными переменными )

0

а точнее что можно добавить приписать или изменить

0

Если я всё правильно понимаю, то а - это и есть глобальная переменная (Её значение можно изменять на протяжении всей программы), если ты хочешь, можно поизвращаться и записать это без ифок

0

А то в тетради пример с записью не имею

0

о покажи как

0

я в тетрадку забыл пример написать

0

а так бы сам написал глобалами

0

Например read(a); writeln(a%2) , Тогда, например, если вернёт 0 - значит число чётно, если 1 - нечётно, но это нахрен не надо потому что по 1 и 0 поймёшь только ты

0

блин (a mod 2) я хотел сказать, с питоном путаю

0

спасибо