Написать программу в паскале(тема циклов) и блок схему : Для различных вводимых с...

0 голосов
90 просмотров

Написать программу в паскале(тема циклов) и блок схему :
Для различных вводимых с клавиатуры целых чисел найдите сумму положительных нечетных.


Информатика (20 баллов) | 90 просмотров
0

А зачем тогда вводить отрицательные и четные, если они потом не рассматриваются?))

Дан 1 ответ
0 голосов

Program kek; Var a, c:integer; Begin c:=0; a:=1; While a<>0 do begin Writeln('Вводите целые числа. Когда закончите - введите "0"'); Readln(a); If (a>0) and (a mod 10 = 1) then do begin c:=c+a; end; End; Writeln(c); End. Вроде так. Нет возможности проверить.

(14 баллов)
0

А блок-схема?

0

Что такое блок схема. Я не понимаю.

0

Нельзя научиться писать программы, не изучив понятия блок-схемы. Так что Ваш вопрос говорит о том, что Вы ответ откуда-то списали.

0

Я не списывал.

0

тогда Вы придуряетесь, говоря, что не знаете о блок-схемах.

0

третьего тут не дано

0

Как хотите

0

Мне, в общем-то все равно, лишь бы автора вопроса устроила.