Написать программу в паскале(тема циклов) : Для различных вводимых с клавиатуры целых...

0 голосов
67 просмотров

Написать программу в паскале(тема циклов) :
Для различных вводимых с клавиатуры целых чисел найдите сумму положительных нечетных


Информатика (20 баллов) | 67 просмотров
Дан 1 ответ
0 голосов

Var a,n,s,i : integer;
begin
  writeln('Число чисел');
  readln (n);
  s:= 0;
  for i:=1 to n do begin
   readln(a);
   if  (a mod 2 <>0) and (a>0) then s:= s+a;
end;
writeln (s) ;
end.

(13.9k баллов)