Написать программу по блок-схеме

0 голосов
49 просмотров

Написать программу по блок-схеме


image

Информатика (17.7k баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
if a>b
  then if a              else if b>c then writeln(b,' - среднее')
                         else writeln(c,' - среднее')
 else if a>c then writeln(a,' - среднее')
              else if b                         else writeln(c,' - среднее');
end.

Пример:
a=7
b=5
c=2
5 - среднее

(194k баллов)
0

Можно проще записать (изменив блок-схему)   var a,b,c,mn,mx,sr: real;
begin
  write('задайте a,b,c  ');  readln(a,b,c);
  mx:=max(a,max(b,c));
  mn:=min(a,min(b,c));
  sr=a+b+c-max-min;
  if a=sr then writeln('среднее а = ',a)
  else if b=sr then writeln('среднее b = ',b)
  else writeln('среднее c = ',c);
end.

0

Спасибо всем огромное:)