2. Напишите программу вычисления в массиве из n элементов, заданных датчиком случайных...

0 голосов
41 просмотров

2. Напишите программу вычисления в массиве из n элементов, заданных датчиком случайных чисел из промежутка от -11 до 14, суммы всех чисел, кратных 3.


Информатика (14 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

Такие задачи здесь разбирались  уже много раз. Как вариант можно предложить такое решение:
//Pascal
const n = 100;
var a:array[1..n] of integer;
  i,s,m:integer;
begin
  readln(m);
  s:=0;
  for i:=1 to m do begin
    a[i]:=random(26)-11;
    if a[i] mod 3=0 then s:=s+a[i];
  end;
  writeln(s);
 end.

(13.9k баллов)