Всем привет. Как написать программу в паскале чтобы она вывела ** экран все числа от 1...

0 голосов
39 просмотров

Всем привет. Как написать программу в паскале чтобы она вывела
на экран все числа от 1 до 100, только таким образом
1,2,5,6,9,10,13,14,17,18,21,22,25,26,29,30
и т.д Надеюсь закономерность поняли. Заранее огромное спасибо!


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

//PascalABC.NET
//NaaMan
var i:integer;
begin
   for i:=1 to 100 do
       if (i mod 4 =1) or (i mod 4=2) then write(i,', ');
   writeln;
end.

(5.6k баллов)