Вопрос ** 20 баллов!!!!! Надо написать программу ** языке паскаль, где надо ввести 5...

0 голосов
35 просмотров

Вопрос на 20 баллов!!!!! Надо написать программу на языке паскаль, где надо ввести 5 любых чисел и программа покажет какое йз них наибольшее. Зарание спасибо)


Информатика (243 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,i,max:integer;
begin
max:=-30000;
  for i:=1 to 5 do begin
     readln(a);
     if a>max then max:=a;
  end;
  writeln('Максимальное  - ', max);
end.


(13.9k баллов)
0

а она на 5 переменных?

0

Переменная одна, только в цикле она 5 раз меняет значение

0

так там надо 5 разных переменных

0

которые ты самм ввеодишь

0

но я прогу плпробую

0

Тогда формулировка задачи должна быть другая

0

сделаешь плиз)

0

Вы поймите, что преподаватель от вас хочет получить программу, которая находит максимальное из пяти введенных значений, а не из 5 переменных.

0

Внимательно читайте условие

0

ок