Напишите программу, которая считает сумму цифр введённого числа. Язык Python. Спасибо,кто...

0 голосов
247 просмотров

Напишите программу, которая считает сумму цифр введённого числа.
Язык Python. Спасибо,кто поможет


Информатика (15 баллов) | 247 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Ну я бы на Питоне сделал бы это так:

n = input()
s = 0
for i in n:
    s += int(i)
print("Сумма цифр:", s)

Небольшая хитрость. На входе получаем не число, а строку. А дальше каждый символ строки переводим в цифру и суммируем.

(13.9k баллов)
0

А вот как хвалёный и многими любимый Пайтон приручить - я не знаю.

0

Мы получим 1234, а хотели 12345678

0

Даст, но не слетит. А не факто, что 12345678 хотели. Может хотели 12344678 и попали не в ту клавишу

0

Программа не должна в общем случае угадывать, что "хотели".

0

Вот, здесь я полностью с вами согласен. Что ввели - то ввели

0

Была такая программка Punto Switcher - для чатов она неплоха, но меня она почему-то считала одесским евреем и все время заменяла при набое текста программы "if" на "ша"

0

Да, помню такую навязчево вставляла все, что ей казалось правильным

0

По той же причине у меня на телефоне Т9 отключен

0

А я отключил во всех приложениях на телефоне фуекцию автодобавления

0

Эх, хорошая тема для общения. Но вынужден покинуть вас. Супруга пообещала что-то сделать с моим компьютером, если я сейчас не оторвусь от него. Так что успехов!