Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Использовать только Repeat программа ПАСКАЛЬ 40 БАЛЛОВ
( k/10 )
надо было во вритлн написать что якобы среднее арифметическое = там например 17
var m,i,l:longint; k,n:real; begin repeat readln(n); k:=k+n; inc(i); until i>9; writeln(k/10:0:0);readln;end.
а так?
либо в врителн без :0:0
Вообще переменные i и k надо бы инициализировать:)
вообщем закосячил я здесь)))
да без 0 0 надо вроде
ну ка надо переделывать
не рабит
Var i: integer; sr, s, x: real; begin i:=0; repeat readln(x); s:=s+x; i:=i+1; until i=10; sr := s/10; writeln(sr); end.
x-то тоже real должен быть
)))
Беда с вами) Тогда и s тоже)
да да , вот че среднее выводит вритон
Var i, n: integer; S, k: real; begin n := 10; S := 0; repeat writeln('Print number'); readln(k); S := S + k; n := n - 1; until n = 0; writeln(S / 10); end.