Написать программу которая находит сумму и произведение чисел от 5 до 50 с шагом 5

0 голосов
115 просмотров

Написать программу которая находит сумму и произведение чисел от 5 до 50 с шагом 5


Информатика (14 баллов) | 115 просмотров
Дано ответов: 2
0 голосов

Var sum,pro,i:integer;
begin
    i:=5;
    sum:=0;
    pro:=1;
    while i<=50 do begin<br>        sum:=sum+i;
        pro:=pro*5;
        i:=i+5;
   end;
   writeln('Сумма = ',sum,', Произведение = ',pro); 
end.

(3.3k баллов)
0

Var s,i : Integer;

0

не туда написал )

0

Фура, произведение таких чисел не влезает в тип Integer.

0

К тому же у Вас не произведение чисел, а домножение на 5.

0

Проглядел... вместо 5 нужно было i поставить. Когда запускал выдало вполне адекватный ответ, потому про тип и не думал даже.

0 голосов

Var s,p : BigInteger;
  i : Integer;
Begin
  p:=1; s:=0;
  For i:=1 to 10 do
  Begin
    s:=s+i*5;
   p:=p*i*5;
  end;
  Writeln('Сумма: ',s);
  Writeln('Произведение: ',p);
end.

(5.1k баллов)