1.дано целое число n>-10 составьте программу которая вычисляет сумму через от -10 до n...

0 голосов
152 просмотров

1.дано целое число n>-10 составьте программу которая вычисляет сумму через от -10 до n
2.дано целое число n (n<100) составьте программу которая вычисляет среднее арифметическое чисел от n до 100<br> 3.дано целое число n>10 составьте программу которая вычисляет сумму через от 10 до n
4.даны действительное число a, натуральное число n, составьте программу которая вычисляет a^n Операцию в возведения в степень не использовать
5. даны целые числа n и m(n6 данно натуральное число a составьте программу котрая находит сумму( фото формулы под текстом)


image

Информатика (89 баллов) | 152 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1.
program myprogram;
var n : integer;
 a1, a2 : real;
begin readln(n);
 writeln((n + 11) * (n - 10) div 2);
end.

2.
program myprogram;
var n : integer;
 a1, a2 : real;
begin readln(n);
 writeln(((100 - n + 1) * (n + 100) div 2) / (100 - n + 1));
end.

3.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
 writeln((n - 9) * (n + 10) div 2);
end.
4.
program myprogram;
var
n, i : integer;
a1, a2 : real;
begin
read(n);
read(a1);
a2:=a1;
for i:=1 to n do a1:=a1*a2;
writeln(a1);
end.

5.
program myprogram;
var
n,m, i, ans : integer;
begin
read(n);
read(m);
ans:=0;
for i:=n to m do ans := ans + i*i;
writeln(ans);
end.

6.
program myprogram;
var
n, i, ans : integer;
begin
read(n);
ans:=0;
for i:=n to 2*n do ans := ans + i*i;
writeln(ans);
end.









(1.2k баллов)
0

тебе срочно?

0

желательно

0

ну что? поможешь?

0

позже

0

а примерно во сколько?

0

тут те самые задачи я скинул http://znanija.com/task/17234811

0

Спасибо большое, а 5 и 6 можешь?

0

а вот 5 задача там формула как под фото?

0

теперь да

0

Огроменное тебе спасиб