Программирование ** языке Паскаль; Напишите программу нахождения числа из трех, которое...

0 голосов
40 просмотров

Программирование на языке Паскаль;

Напишите программу нахождения числа из трех, которое находится посередине.
Спасибо


Информатика (15 баллов) | 40 просмотров
0

Нет условия (перепишите полностью условие)

0

то что написано уже и так понятно

0

Среднее арифметическое что ли?

0

думаю в данном случае то, которое больше одного и меньше другого

0

возможно

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,sr: real;
begin
  write('задайте a,b,c  ');  readln(a,b,c);
  sr:=a+b+c-max(a,max(b,c))-min(a,min(b,c));
  if a=sr then writeln('среднее а = ',a)
  else if b=sr then writeln('среднее b = ',b)
  else writeln('среднее c = ',c);
end.

(9.7k баллов)
0

Srzontmp, не во всякой версии Паскаля предопределена функция MAX и MIN - так что либо распишите ее отдельно, либо уточняйте версию Паскаля у автора вопроса.

0

Признаться, мне не доводилось встречаться с трансляторами, в которых нет встроенных функций max(a,b)  и min(a,b),  это наверно совсем какой-то убогий транслятор.

0

TurboPascal может и убогий, но с него все начиналось. Но есть например FreePascal - который убогим уже не назовёшь - сейчас специально в нём проверил - выдал ошибку на MAX

0

А библиотека Math подключена?  Это минимальный набор стандартных функций. Или, может быть, тогда и для sin, cos, tg свои процедуры - функции писать?

0

sin и cos как раз встроенные... а если уж нужно подключать библиотеку, то опять же - в коде этого не указано... потому и говорю - либо расписываешь функции сам (они маленькие) , либо уточнять версию требуемого компилятора.

0

Вопрос все равно будет удален, отмечен как нарушение, поэтому, чего копья ломать?