Написать программу, которая вычисляет частное двух чисел. Программа должна проверять...

0 голосов
124 просмотров

Написать программу, которая вычисляет частное двух чисел.
Программа должна проверять правильность введенных пользователем
данных и, если они неверные (делитель равен нулю), вы-
давать сообщение об ошибке. Ниже приведен рекомендуемый
вид экрана во время выполнения программы (данные, введенные
пользователем, выделены полужирным шрифтом).


Информатика (12 баллов) | 124 просмотров
Дано ответов: 2
0 голосов

//Деление с проверкой
var a,b:real;
begin
readln(a,b);
if b<>0 then writeln('Частное ', a/b)
  else
  writeln('Деление на 0');
end.

(13.9k баллов)
0 голосов

Var
a, b: real;
begin
readln(a, b);
If b = 0 then
writeln('Делитель равен нулю!')
else
writeln(a/b);
end.

(2.7k баллов)