Напишите программу (в Паскаль) для функции у=х(в кубе)-1 ** интервале [-1,3] с шагом 0.2...

0 голосов
241 просмотров

Напишите программу (в Паскаль) для функции у=х(в кубе)-1 на интервале [-1,3] с шагом 0.2 на трех разных циклах (ДО,ПОКА,ДЛЯ)


Информатика (72 баллов) | 241 просмотров
Дан 1 ответ
0 голосов
Оно?

var x, y: integer;  
begin write ('x = ');
readln (x);
      if x > 0 then y := x - 2 else if x = 0 then y := 0 else y := abs (x);  
writeln ('y = ', y);  
readln end.
(20 баллов)