Паскаль. f(x)= -3х^2-x^2-x, если х<=-2 или 2х^2-3х, если х>-2 нужно составить программу,...

0 голосов
30 просмотров

Паскаль. f(x)= -3х^2-x^2-x, если х<=-2 или 2х^2-3х, если х>-2

нужно составить программу, помогите, пожалуйста.


Информатика (12 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

 Program Funct;

Uses Crt;

var x,rez:real;

begin

     clrscr;

     write('Введите x:');

     readln(x);

     if (x<=-2) then rez:=-3*(x*x)-(x*x)-x</p>

         else rez:=2*(x*x)-3*x;

     writeln('f(x)=',rez:5:5);   

     readkey;

 

end. 

 

 

(2.4k баллов)