Написать программу для pascаl: вычислить произведение всех четных чисел от 50 до 100

0 голосов
31 просмотров

Написать программу для pascаl: вычислить произведение всех четных чисел от 50 до 100


Информатика (57 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

Var
  i:integer;
  p:biginteger;
begin
  p := 1;
  for i := 50 to 100 do
    if i mod 2 = 0 then p := p * i;
  writeln(p);  
end.

Тестовое решение:
3289645422013119007424590987918048021708800000000

(13.9k баллов)
0

mod? Что это значит?

0

Остаток от деления