Задача по информатике. У Васи 5 яблок, а у Пети 4 яблока. Василий грустит из-за голода....

0 голосов
36 просмотров

Задача по информатике.
У Васи 5 яблок, а у Пети 4 яблока. Василий грустит из-за голода. Какое решение примут друзья, чтоб всем трем мальчикам досталось одинаковое количество яблок?
Написать программу так, чтоб в ней присутствовали математические операции, а на экран выводилось сообщение с подробным описанием решения задачи.
решение на языке с++


Информатика (22 баллов) | 36 просмотров
0

1-й мальчик - Вася, 2-й - Петя, а 3-й кто?

Дан 1 ответ
0 голосов
Правильный ответ

Программа:
#include
using namespace std; 
int main()
{
    int a=5;
    int b=4;
    int c;
    cout << "Количество яблок у Васи = " << a << "\n";<br>    cout << "Количество яблок у Пети = " << b << "\n";<br>    cout << "Количество яблок у Васи и Пети вместе = " << a+b << "\n";<br>    c=(a+b)/3;
    cout << "Если разделить на 3-х поровну, то получится = " << c << "\n";<br>    return 0;
}

Результат:
Количество яблок у Васи = 5
Количество яблок у Пети = 4
Количество яблок у Васи и Пети вместе = 9
Если разделить на 3-х поровну, то получится = 3

(194k баллов)