Помогите,пожалуйста,написать программу в PascalABC спасибо!

0 голосов
28 просмотров

Помогите,пожалуйста,написать программу в PascalABC
спасибо!


image

Информатика (2.7k баллов) | 28 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var s:=ReadlnString('Введите полный путь:');
  Writeln('Расширение файла: ',ExtractFileExt(s)[2:s.length])
end.

Тестовое решение:
Введите полный путь: H:\PABCWork.NET\Samples\ABCObjects\Test1.pas
Расширение файла: pas

(142k баллов)
0 голосов

Программа написана с учетом того, что символ "." в строке обязательно есть (т.е. без контроля ввода).
var s,s1:string; i:integer;
begin
writeln('Введите строку:');
readln(s);
s1:='';
i:=length(s);
while s[i]<>'.' do
 begin
 s1:=s[i]+s1;
 i:=i-1;
 end;
writeln('Расширение файла - ',s1);
end.

Пример:
Введите строку:
С:\учёба\математика\ГИА\Расписание.txt
Расширение файла - txt

(194k баллов)
0

спасибо большое :)

0

Пожалуйста