Помогите пожалуйста решить программу !!!!!!!!!! ** Pascal ABC. с random и randomize!!!!!!...

0 голосов
48 просмотров

Помогите пожалуйста решить программу !!!!!!!!!! на Pascal ABC.
с random и randomize!!!!!!
ОЧЕНЬ СРОЧНО!!!!!!!!
Задача:
Найти количество четных чисел из 20 целых случайных чисел из любого интервала.


Информатика (159 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Ну функция randomize() создаёт, перемешивает новые рандомные числа, а random() их предоставляет.
Разных вариаций написания много, я например сделал с массивом, можно в принципе и без него, но с ним лучше т.к. числа хранятся в массиве и их можно выводить в будущем, если это слишком сложно для тебя, то я могу написать программу без использования массива.

Var i,b:integer;
    A:array[1..20] of integer;
Begin
  Randomize();
  for i:=1 to 20 do
  A[i]:=Random(0,50);
Write('Из чисел: ');
   for i:=1 to 20 do
    begin
    if i=20 then
      Writeln(A[i])
       else Write(A[i],', ')
    end;
Write('Кол-во четных равняется: ');
  for i:=1 to 20 do
             if (A[i] mod 2 = 0) then b:=b+1;
Writeln(b)
End
.

Вот выводы программы, которые у меня получились.

Первый раз:

Из чисел: 42, 1, 46, 24, 36, 9, 22, 16, 7, 41, 49, 46, 27, 29, 50, 44, 44, 10, 48, 36
Кол-во четных равняется: 13

Второй раз:

Из чисел: 5, 16, 16, 27, 1, 48, 46, 45, 46, 13, 21, 18, 24, 45, 14, 13, 33, 14, 21, 30
Кол-во четных равняется: 10

Третий раз:

Из чисел: 15, 2, 24, 42, 49, 43, 5, 48, 8, 1, 45, 9, 20, 24, 35, 19, 11, 15, 26, 33
Кол-во четных равняется: 8

Файл с кодом прикреплю во вложения, спрашивай если не понятна какая-то функция, объясню, дабы ты не стоял в ступоре перед учительницей...

(8.6k баллов)