C++Напишите программу, которая заполняет массив из N элементов членами арифметической...

0 голосов
131 просмотров

C++Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D .

Входная строка содержит три целых числа: начальное значение X , разность D и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 .

Программа должна вывести содержимое массива: N первых членов арифметической прогрессии с начальным значением X и разностью D .
входные данные
8 4 5
выходные данные
8 12 16 20 24


Информатика (73 баллов) | 131 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main()
{
setlocale (0,"");
string mas [20];
int x;
int n;
int d;
cout<<"введите начальное число x: ";<br> cin >> x;
cout<<"введите число членов массива n: ";<br> cin >> n;
cout<<"введите разность чисел d: ";<br> cin >> d;
for (n;n>=1; n--)
{
cout<<x<<endl;<br> x=x+d;
}
return 0;
}

(8.6k баллов)
0

неправильно, не списывай