Составить программу ** языке Паскаль для задачи: ввести два целых числа Х и Y и выяснить,...

0 голосов
33 просмотров

Составить программу на языке Паскаль для задачи:
ввести два целых числа Х и Y и выяснить, что больше их сумма или произведение. в качестве результата печатать "сумма" или "произведение" или "равно"


Информатика (22 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

Var
  x, y: integer;

begin
  readln(x,y);
  if x=y then writeln ('Равны') else
  if (x+y) > (x*y) then writeln ('Cумма')
    else if (x+y)<(x*y) then writeln ('Произведение')<br>end.

Тест №1
22 55
Произведение

Тест №2
1 6
Cумма

Тест №3
22 22
Равны





(13.9k баллов)
0

if (x+y)<(x*y) - это уже можно было и не писать

0

Чисто только из голимого занудства таки скажу, что если взять числа 22 и 22, то их сумма не будет равна их произведению. И вообще, для почти любых двух одинаковых чисел их сумма будет отличаться от их же произведения, за исключением, наверное, только 2 и 2.