Напишите программу, которая вводит номер месяца и выводит название времени года **...

0 голосов
598 просмотров

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.
Входные данные
Входная строка содержит единственное число – номер месяца (возможно, неверный).

Выходные данные
Нужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.


Информатика (200 баллов) | 598 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n: integer;
begin
  read(n);
  case n of
    12, 1, 2: writeln('winter');
    3..5: writeln('spring');
    6..8: writeln('summer');
    9..11: writeln('autumn');
    else writeln('NO')
  end
end.

(13.3k баллов)
0 голосов

Можно еще вот так :)


image
(24.9k баллов)