Помогите пожалуйста с домашней работой. Напишите программу, которая вычисляет сумму: а)...

0 голосов
37 просмотров

Помогите пожалуйста с домашней работой.
Напишите программу, которая вычисляет сумму:
а) первых n натуральных чисел;
б) квадратов первых n натуральных чисел;
в) всех чётных чисел в диапазоне от 1 до n;
г) всех двузначных чисел.


Информатика (49 баллов) | 37 просмотров
0

Язык программирования какой?

0

pascal скорее всего

Дан 1 ответ
0 голосов
Правильный ответ

A) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+i;
writeln(s);
end.

б) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do s:=s+(i*i);
writeln(s);
end.

в) var s, i, n :integer;
begin
s:=0;
readln(n);
for i:= 1 to n do
begin
if (i mod 2 = 0) then s:=s+i;
end;
writeln(s);
end.

г) var s, i :integer;
begin
s:=0;
for i:= 10 to 99 do s:=s+i;
writeln(s);
end.

(362 баллов)
0

Спасибо большое.