Напишите программу, которая вводит натуральные числа a и b и выводит сумму квадратов натуральных чисел в диапазоне от а до b. Что не так,как исправить?
Надо после do написать begin А после writeln(k); пиши end; Когда указывают больше двух действий надо оборачивать в begin и end.
не получилось,такая же ошибка...
Напиши код.
А вообще попробуй k:=k+1^2 написать в скобках т.е. (k:=k+1^2)
program qq; var n,m,k,i,l,a,b:longint; begin readln(a,b); for i:=a to b do begin (k:=k+i^2); writeln(k); end; end.
Извини, я вообще без понятия
да ничего
а зачем ты ввёл столько переменных
k:=k+i^2 вместо этого попробуй k:=k+sqr(i)