Pascal ABC. Составьте программу, которая рисует деталь в виде кольца внешним радиусом 150...

0 голосов
144 просмотров

Pascal ABC. Составьте программу, которая рисует деталь в виде кольца внешним радиусом 150 и внутренним радиусом 50, в котором вырезаны отверстия радиусом 30. Их центры находятся на расстоянии 100 от центра кольца (число отверстий n вводится с клавиатуры). 2


Информатика (104 баллов) | 144 просмотров
Дано ответов: 2
0 голосов

Program grapho; uses crt,graphABC; var xc,yc,r1,r2,rc,ro,n,i,x,y:integer;     a:real; beginrepeatwrite('Количество отверстий от 3 до 7 n='); read(n); until n in[3..7]; clrscr; hidecursor; xc:=windowwidth div2; yc:=windowheight div2; r1:=50; r2:=150; rc:=100; ro:=30; a:=2*pi/n; circle(xc,yc,r2); circle(xc,yc,r1);   for i:=1 to n do  begin   x:=xc+round(rc*cos(a*i));   y:=yc-round(rc*sin(a*i));   circle(x,y,ro);  end; end.

(158 баллов)
0 голосов

program Risovalka;

  uses crt,graphABC;

  var xc,yc,r1,r2,rc,ro,n,i,x,y:integer;

  a:real;

    begin repeatwrite('ykashi shislo otverstii ot 5 do 10 n=');

    read(n);

   until n in [5..10];

   clrscr; hidecursor;

    xc:=windowwidth div 2;

    yc:=windowheight div 2;

   r1:=40;

   r2:=120;

   rc:=100; ro:=30;

   a:=2*pi/n;

   circle(xc,yc,r2);

    circle(xc,yc,r1);

     for i:=to n do  begin   x:=xc+round(rc*cos(a*i));

      y:=yc-round(rc*sin(a*i));

      circle(x,y,ro);

      end.

(56 баллов)