Помогите в паскале составить программу даны 3 числа если среди них больше чётных то числа...

0 голосов
46 просмотров

Помогите в паскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1


Информатика (12 баллов) | 46 просмотров
0

сейчас на пишу

0

Составно́е число́ — натуральное число большее 1, не являющееся простым. Каждое составное число является произведением двух натуральных чисел больших 1. Последовательность составных чисел начинается так: 4, 6, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, …

Дан 1 ответ
0 голосов

Const N = 3;
var a: array[1..N] of integer;
i, x: integer;
begin
x:=0;
for i:=1 to N do begin
read(a[i]);
if a[i] mod 2 = 0 then
x:=x+1;
end;
if 2*x >= N then
for i:=1 to N do begin
a[i]:=a[i]*2;
writeln(a[i]);
end
else
for i:=1 to N do begin
a[i]:=a[i]+1;
writeln(a[i]);
end;
end.



(2.7k баллов)
0

const N = 3; var a: array[1..N] of integer; i, x: integer; begin x:=0; for i:=1 to N do begin read(a[i]); if a[i] mod 2 = 0 then x:=x+1; end; if 2*x >= N then for i:=1 to N do begin a[i]:=a[i]*2; writeln(a[i]); end else for i:=1 to N do begin a[i]:=a[i]+1; writeln(a[i]); end; end.