Помогите пожалуйста написать программу ** паскале турбо которая будет выводить все суммы...

0 голосов
45 просмотров

Помогите пожалуйста написать программу на паскале турбо которая будет выводить все суммы числа 50 или n числа


Информатика (15 баллов) | 45 просмотров
0

Это как?

0

ну чтоб оно само считало и выводил чила 49+1,48+2,47+3 и так далие

0

Т.е. пары? или любые наборы чисел, дающие в сумме 50?

0

Можно же 47+1+1+1, 45+3+2, .... и т.п.

0

пары

0

Поздно

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
for b:=1 to a-1 do begin  writeln(a-b,' + ',b,' = ',a);
end;
end.

(8.6k баллов)