Написать программу которая для заданного натурального числа n вычисляет сумму...

0 голосов
90 просмотров

Написать программу которая для заданного натурального числа n вычисляет сумму
1+1/1+2+1/1+2+3+···+1/1+2+···n в паскале .


Информатика (27 баллов) | 90 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
  readln(n);
  s:=0;s1:=0;
  for i:=1 to n do begin
    s1:=s1+i;
    s:=s+1/s1;
  end;
  writeln (s);
  end.
 

(13.9k баллов)
0

Здесь вычисляется сумма другого ряда 1+1/2+1/3+1/4+ ....

0

Спасибо! Исправил ...

0 голосов

Var s: real;    n,sn,i: integer;begin  write('n = ');  readln(n);  s:=0;  sn:=0;  for i:=1 to n do  begin    sn:=sn+i;    s:=s+1/(sn);    writeln(s);  end;  writeln('сумма ряда:  ',s);end.    

(9.7k баллов)