Составить алгоритм и написать программу: Мальчик , продающий ** улице газеты,...

0 голосов
314 просмотров

Составить алгоритм и написать программу:
Мальчик , продающий на улице газеты, зарабатывает F рублей на продаже каждой из первых 75 газет. На каждой из остальных газет он зарабатывает по Х копеек. Сколько заработает мальчик, если он продаст 133 газеты. (Ответ дать в рублях и копейках)


Информатика (76 баллов) | 314 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var f,x,sr,sk:integer;
begin
write('f (руб) = '); readln(f);
write('x (коп) = '); readln(x);
sr:=75*f + (133-75)*x div 100;
sk:=(133-75)*x mod 100;
writeln('Заработок = ',sr,' руб ',sk,' коп');
end.

Пример:
f (руб) = 2
x (коп) = 40
Заработок = 173 руб 20 коп

(194k баллов)