Напишите программу формирования и вывода массива размером 6x3, каждые три...

0 голосов
89 просмотров

Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен удвоенному числу, введенному с клавиатуры;
2-й — равен квадрату суммы индексов предыдущего элемента;
3-й — равен остатку от деления индекса текущего элемента на 2.


Информатика (902 баллов) | 89 просмотров
0

то есть пользователь должен по ходу программы ввести 6 чисел?

0

и массив 1 2 3 1 2 3 или 1 2 3 4 5 6 1 2 3 4 5 6

0

да 6 чисел

Дан 1 ответ
0 голосов

Сделал задачу по условию, которое понял.
var 
a: array[1..3, 1..6] of integer; 
i, j: integer;
begin 
Writeln('Введите 6 чисел через Enter '); 
for i := 1 to 3 do   
for j := 1 to 6 do     
case j of       
1, 4: begin Readln(a[i, j]);a[i, j] := 2 * a[i, j]; end;       
2, 5: a[i, j] := sqr(i + j - 1);       
3, 6: a[i, j] := j mod 2;     
End; 
Writeln('Сформированный массив ');      
for i := 1 to 3 do   begin   
for j := 1 to 6 do     
write(a[i, j], ' ');   
Writeln;
end;
end.

(2.6k баллов)
0

Если что не так, объясняй переделаю.