C++Напишите программу, которая заполняет массив из N элементов членами арифметической...

0 голосов
395 просмотров

C++Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D в обратном порядке, так чтобы последний элемент был равен X .

Входные данные
Входная строка содержит три целых числа: начальное значение X , разность D и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести содержимое массива: N первых членов арифметической прогрессии с начальным значением X и разностью D в обратном порядке, так что последний элемент массива равен X .

Примеры
входные данные
5 3 6
выходные данные
20 17 14 11 8 5


Информатика (73 баллов) | 395 просмотров
Дан 1 ответ
0 голосов

#includeusing namespace std;int main(){int n,x,D;cin>>x>>D>>n;inta[n];a[n]=x;for(int i=n-1;i>0;i--){a[i]=x+D;x=a[i];}for(int i=1;i<=n;i++)<br>cout<<a[i]<<' ';return 0;}<hr>image

(262 баллов)