Помогите написать программу к задаче: В программе генерируется два случайных числа a и b...

0 голосов
57 просмотров

Помогите написать программу к задаче: В программе генерируется два случайных числа a и b в диапазоне от 10 до 40. Определить какое число больше?


Информатика (834 баллов) | 57 просмотров
0

На чем прога?

Дан 1 ответ
0 голосов
Правильный ответ

Если паскаль, лови...
Во первых для генерации рандомного числа используется метод random(x), но он генерирует число от 1 до x, и чтоб он генерировал от какого то определенного, надо из x вычесть от какого числа генерировать, а потом к сгенерированному прибавить его random(x - n) + n. Где x - До какого числа, а n - от какого. 
Для нахождения максимального числа мы будем использовать метод max, который принимает два аргумента (какие числа надо сравнить), допустим max(5,10) вернет 10, max(-1, -5) вернет -1. Так же есть min - нахождение минимального.
...
А теперь сам код:
begin
var a := random(30) + 10; 
var b := random(30) + 10;
writeln('a:' + a); 
writeln('b:' + b);
writeln(max(a,b)); 
end.
...
Если не сложно нажми "Спасибо" ;)

(198 баллов)