Написать программу которая получает два целых числа и находит их произведение не...

0 голосов
34 просмотров

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть
отриц


Информатика (17 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a,b:integer;
  Write('Введите два целых числа: '); Read(a,b);
  if (a=0) or (b=0) then Writeln('Произведение равно нулю')
  else begin
    var s:=1;
    if sign(a)<>sign(b) then s:=-1;
    a:=abs(a);
    var p:=0;
    for var i:=1 to abs(b) do p+=a;
    if s=1 then Writeln('Произведение равно ',p)
    else Writeln('Произведение равно ',-p)
    end
end.

(142k баллов)
0

Извините, но нужно в c ++

0

Не извиню! Где это написано?

0

Комментарии вида "мне надо было иначе" я воспринимаю, как наплевательство на чужой труд, когда автор вопроса не потрудился даже указать, что именно он хочет: "Ну подумаешь, не так напишут, я попрошу переделать..."