1)Напишите программу которая вычисляет сумму квадратов первых n-натуральных...

0 голосов
447 просмотров

1)Напишите программу которая вычисляет сумму квадратов первых n-натуральных чисел.2)Вводится последовательность целых чисел. Последовательность оканчивается нулём,вывести максимальное число Срочно!


Информатика (27 баллов) | 447 просмотров
Дан 1 ответ
0 голосов

Var
  n,i,s:integer;
Begin
  write('Введите число n: ');
  Readln(n);
  for i:= 1 to n do
  s:=s+sqr(i);
  write(s);
End.

2.
Var
  a,max:integer;
Begin
  repeat
  write('Введите число ');
  Readln(a);
  if a>max then max:=a;
  until a=0;
  write(max);
End.

(2.6k баллов)
0

со вторым проблема постоянно пишет введите число, так должно быть ?

0

Все понял спасибо большое